Vulnerability · Published Mar 11, 2026 · Assigned by Neo4j
CVE-2026-1524Auth misconfiguration when multiple providers enabled
Low 2.1
In plain English
A low-severity incorrect authorization in Enterprise Edition from neo4j. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities).
Official description
An edgecase in SSO implementation in Neo4j Enterprise edition versions prior to version 2026.02 can lead to unauthorised access under the following conditions: If a neo4j admin configures two or more OIDC providers AND configures one or more of them to be an authorization provider AND configures one or more of them to be authentication-only, then those that are authentication-only will also provide authorization. This edgecase becomes a security problem only if the authentication-only provider contains groups which have higher privileges than provided by the intended (configured) authorization provider. When using multiple plugins for authentication and authorisation, prior to the fix the issue could lead to a plugin configured to provide only authentication or authorisation capabilities erroneously providing both capabilities. We recommend upgrading to versions 2026.02 (or 5.26.22) where the issue is fixed.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| neo4j | Enterprise Edition | 4.4.0 – before 5.26.222025.01 – before 2026.02 |
Weakness: CWE-863, CWE-287 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/AU:N/R:U/V:D/RE:M/U:Green
References
- https://neo4j.com/security/CVE-2026-1524 vendor-advisory