Vulnerability · Published Jul 29, 2026 · Assigned by openjs
CVE-2026-15157undici vulnerable to CRLF Injection via blob-like body 'type' property
Medium 4.2
In plain English
A medium-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici does not validate the type property of a duck-typed blob-like request body before using it as the Content-Type header on the HTTP/1.1 dispatcher. In undici before 6.28.0, from 7.0.0 up to before 7.29.0, and from 8.0.0 up to before 8.9.0, an application that passes a hand-rolled blob-like body (via request, stream, pipeline, or dispatch) whose type is derived from untrusted input allows an attacker to inject CRLF sequences and append arbitrary HTTP headers, potentially smuggling a second request past the upstream. Native Blob objects are safe because their constructor strips CRLF from the type, and fetch is unaffected because it validates headers, but ecosystem libraries that build duck-typed blob shapes from user input can reach the vulnerable path. This is the same defect class as CVE-2022-35948 and CVE-2026-1527, on a header sink that the earlier fixes did not cover. The issue is fixed in undici 6.28.0, 7.29.0, and 8.9.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-15157 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-15157 |
| Debian:14 | node-undici | 8.9.0+dfsg+~cs3.2.0-1 | DEBIAN-CVE-2026-15157 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-15157 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-15157 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-15157 |
| npm | undici | 8.9.0 | GHSA-m8rv-5g2x-5cg5 |
| npm | undici | 7.29.0 | GHSA-m8rv-5g2x-5cg5 |
| npm | undici | 6.28.0 | GHSA-m8rv-5g2x-5cg5 |
Affected products (as reported)
Weakness: CWE-93 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N