Vulnerability · Published Jul 29, 2026 · Assigned by openjs
CVE-2026-14643undici vulnerable to cross-user information disclosure via whitespace around equals in Cache-Control directives
Medium 5.9
In plain English
A medium-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici's cache interceptor mishandles optional whitespace placed around the equals sign of a qualified no-cache or private Cache-Control directive. In undici from 7.0.0 up to before 7.29.0 and from 8.0.0 up to before 8.9.0, the parser either drops the directive or stores a field name with literal quote characters, so the cache decision fails to recognize the qualification and the response is stored. In shared-cache mode, this lets a response containing one user's authenticated data be served from cache to a later caller, including an unauthenticated one, when both requests resolve to the same cache key. It affects applications that enable the cache interceptor in shared mode, forward Authorization headers upstream, and receive cacheable responses with qualified directives padded with whitespace around the equals sign. This is the whitespace-around-equals variant that the fix for CVE-2026-9678 did not normalize, and it is fixed in undici 7.29.0 and 8.9.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-14643 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-14643 |
| Debian:14 | node-undici | 8.9.0+dfsg+~cs3.2.0-1 | DEBIAN-CVE-2026-14643 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-14643 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-14643 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-14643 |
| npm | undici | 8.9.0 | GHSA-jr45-8vmc-qm54 |
| npm | undici | 7.29.0 | GHSA-jr45-8vmc-qm54 |
Affected products (as reported)
Weakness: CWE-436, CWE-524 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N