Vulnerability · Published Jul 3, 2026 · Assigned by openjs

CVE-2026-14620webpack-dev-server vulnerable to cross-site request forgery via internal developer endpoints

Medium 4.7

In plain English

A medium-severity cross-site request forgery in webpack-dev-server from webpack-dev-server. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.7Medium
Exploit odds (30 days)0.5%top 55.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

webpack-dev-server versions 5.2.5 and earlier expose two internal developer endpoints, /webpack-dev-server/open-editor and /webpack-dev-server/invalidate, that perform state-changing actions on any GET request without verifying that the request originated from the dev server's own page. Any website a developer visits while the dev server is running can trigger these endpoints cross-origin with no interaction beyond the visit. An attacker can open an arbitrary existing local file in the developer's editor, including files outside the project root, and repeated requests can spawn editor processes and force recompilations that degrade the developer's machine. Patches: upgrade to webpack-dev-server 5.2.6. Workarounds: none.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmwebpack-dev-server5.2.6GHSA-f5vj-f2hx-8m93

Affected products (as reported)

VendorProductVersions
webpack-dev-server webpack-dev-server 0 – before 5.2.6

Weakness: CWE-352, CWE-749 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L

References