Vulnerability · Published Jun 29, 2026 · Assigned by openjs

CVE-2026-13676fast-uri vulnerable to host confusion via failed IDN canonicalization

High 7.5

In plain English

A high-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 53% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.7%top 46.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri versions 2.3.1 through 3.1.2 and 4.0.0 fail to canonicalize Unicode (IDN) hostnames for HTTP-family URLs. The IDN conversion path calls a helper that does not exist on the global URL constructor, silently leaving the host in its original Unicode form while normalize() and equal() still return values that differ from a WHATWG-compatible URL parser. Applications that use fast-uri to enforce host-based policy (denylists, loopback filtering, redirect validation, outbound proxy routing) before passing the same URL to Node's URL or fetch can be bypassed when the two implementations resolve the same input to different hosts. Patches: upgrade to fast-uri 3.1.3 for the 3.x line or 4.0.1 for the 4.x line. Workarounds: enforce host policy using the same URL parser used for the actual request, or reject non-ASCII hosts before policy checks.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-13676
Debian:14node-ajv8.20.0~ds+~cs7.1.2-1DEBIAN-CVE-2026-13676
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-13676
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-13676
Ubuntu:25.10node-ajvno fix listedUBUNTU-CVE-2026-13676
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-13676
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-13676
npmfast-uri2.4.2GHSA-4c8g-83qw-93j6
npmfast-uri3.1.3GHSA-4c8g-83qw-93j6
npmfast-uri4.0.1GHSA-4c8g-83qw-93j6

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 4.0.0 – before 4.0.12.3.1 – before 3.1.3

Weakness: CWE-436, CWE-551 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

References