Vulnerability · Published Jun 23, 2026 · Assigned by AMZN
CVE-2026-12958Arbitrary file write in Language Servers for AWS
High 7.8
In plain English
A high-severity security flaw in Language Servers for AWS from Amazon Web Services. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Missing symlink validation in Language Servers for AWS may allow an arbitrary file write outside of the workspace trust boundary. This may occur when a local user opens a workspace with a maliciously crafted symlink that resolves to a file path outside the workspace trust boundary. To remediate this issue, users should upgrade to version 1.69.0 or higher.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @aws/lsp-codewhisperer | 0.0.117 | GHSA-6v3r-4p5c-mrp5 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Amazon Web Services | Language Servers for AWS | 0 – before 1.69.0 |
Weakness: CWE-61 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://aws.amazon.com/security/security-bulletins/2026-047-aws/ vendor-advisory
- https://github.com/aws/language-servers/security/advisories/GHSA-6v3r-4p5c-mrp5 third-party-advisory