Vulnerability · Published Jun 23, 2026 · Assigned by AMZN
CVE-2026-12957Arbitrary Code Execution in Language Servers for AWS
High 7.8
In plain English
A high-severity incorrect permission assignment in Language Servers for AWS from Amazon Web Services. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @aws/lsp-codewhisperer | 0.0.113 | GHSA-xhcr-j4j9-3gh7 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Amazon Web Services | Language Servers for AWS | 0 – before 1.65.0 |
Weakness: CWE-732 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://aws.amazon.com/security/security-bulletins/2026-047-aws/ vendor-advisory
- https://github.com/aws/language-servers/security/advisories/GHSA-xhcr-j4j9-3gh7 third-party-advisory