Vulnerability · Published Nov 5, 2026 · Assigned by VulDB

CVE-2026-123023agentscope-ai AgentScope Bash Tool _bash.py check_permissions authorization

High 7.3

In plain English

A high-severity incorrect authorization in AgentScope from agentscope-ai. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities).

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.6%top 51.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.

Affected products (as reported)

VendorProductVersions
agentscope-ai AgentScope 2.0.02.0.12.0.22.0.32.0.42.0.52.0.62.0.7

Weakness: CWE-863, CWE-285 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L/E:P/RL:O/RC:C

References