Vulnerability · Published Nov 3, 2026 · Assigned by AMZN
CVE-2026-121652Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering
Medium 5.4
In plain English
A medium-severity cross-site scripting in maplibre-gl-js-amplify from AWS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities).
Official description
Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| AWS | maplibre-gl-js-amplify | 0 – before 4.0.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
References
- https://github.com/aws-amplify/maplibre-gl-js-amplify/releases/tag/v4.0.3 release-notes, patch
- https://github.com/aws-amplify/maplibre-gl-js-amplify/security/advisories/GHSA-34v3-xxqp-g5g9 third-party-advisory
- https://aws.amazon.com/security/security-bulletins/2026-167-aws/ vendor-advisory