Vulnerability · Published Nov 3, 2026 · Assigned by GitLab
CVE-2026-121506Out-of-bounds Write in NTPsec
High 7.4
In plain English
A high-severity out-of-bounds write in NTPsec from NTPsec. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
An out-of-bounds read and write in NTS client extension field parsing (extens_client_recv) in NTPsec before 1.2.5 allows a remote attacker who can send NTP server-mode replies to an NTS client to corrupt heap memory and crash ntpd, and, combined with the NTS-KE client out-of-bounds read fixed in 1.2.4, to bypass NTS authentication and set the client's time, via an NTS Authenticator and Encrypted Extension Fields field whose nonce length exceeds the field.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | ntpsec | no fix listed | DEBIAN-CVE-2026-121506 |
| Debian:13 | ntpsec | no fix listed | DEBIAN-CVE-2026-121506 |
| Debian:14 | ntpsec | 1.2.5+dfsg-1 | DEBIAN-CVE-2026-121506 |
| Ubuntu:22.04:LTS | ntpsec | no fix listed | UBUNTU-CVE-2026-121506 |
| Ubuntu:24.04:LTS | ntpsec | no fix listed | UBUNTU-CVE-2026-121506 |
| Ubuntu:26.04:LTS | ntpsec | no fix listed | UBUNTU-CVE-2026-121506 |
| Ubuntu:26.10 | ntpsec | no fix listed | UBUNTU-CVE-2026-121506 |
Affected products (as reported)
Weakness: CWE-787 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H