Vulnerability · Published Oct 29, 2026 · Assigned by GitHub_M

CVE-2026-119286GraphQL-core: Denial of service via memory leak in aborted validations

High 7.5

In plain English

A high-severity uncontrolled resource consumption in graphql-core from graphql-python. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 63.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

GraphQL-core is a Python port of the GraphQL.js reference implementation. From 3.3.0a3 until 3.3.1, validate() reuses a module-level ValidationAbortedError when a document exceeds max_errors. Python appends frames to the reused exception's traceback on every raise, retaining each document, validation context, and error set for the process lifetime. An unauthenticated client can repeatedly submit a small document with more than 100 validation errors to cause unbounded memory growth before query execution, eventually exhausting worker memory without disclosing or modifying data. This issue is fixed in version 3.3.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIgraphql-core3.3.1GHSA-mpqx-q82w-9x46
Ubuntu:22.04:LTSgraphql-coreno fix listedUBUNTU-CVE-2026-119286
Ubuntu:24.04:LTSgraphql-coreno fix listedUBUNTU-CVE-2026-119286
Ubuntu:26.04:LTSgraphql-coreno fix listedUBUNTU-CVE-2026-119286
Ubuntu:26.10graphql-coreno fix listedUBUNTU-CVE-2026-119286

Affected products (as reported)

VendorProductVersions
graphql-python graphql-core >= 3.3.0a3, < 3.3.1

Weakness: CWE-400, CWE-401 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References