Vulnerability · Published Oct 29, 2026 · Assigned by GitHub_M

CVE-2026-119197pyasn1: Quadratic-complexity denial of service in binary REAL decoding

High 7.5

In plain English

A high-severity security flaw in pyasn1 from pyasn1. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 63.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.5, binary REAL decoding builds a large mantissa one octet at a time by shifting a growing integer and slicing the remaining byte string. Attacker-controlled ASN.1 includes a binary-encoded REAL with a large mantissa and reaches BER, CER, or DER decode(), with or without a schema containing REAL. RealPayloadDecoder.valueDecoder repeatedly performs a left shift, OR, and suffix copy for every mantissa octet, making decode time quadratic in mantissa length. A comparatively small REAL value can hold a decoding worker on one CPU core for seconds or longer and cause availability loss. This issue is fixed in version 0.6.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12pyasn1no fix listedDEBIAN-CVE-2026-119197
Debian:13pyasn1no fix listedDEBIAN-CVE-2026-119197
Debian:14pyasn10.6.5-1DEBIAN-CVE-2026-119197
PyPIpyasn10.6.5GHSA-mm57-4v3p-rchx
Ubuntu:22.04:LTSpyasn1no fix listedUBUNTU-CVE-2026-119197
Ubuntu:24.04:LTSpyasn1no fix listedUBUNTU-CVE-2026-119197
Ubuntu:26.04:LTSpyasn1no fix listedUBUNTU-CVE-2026-119197
Ubuntu:26.10pyasn1no fix listedUBUNTU-CVE-2026-119197

Affected products (as reported)

VendorProductVersions
pyasn1 pyasn1 < 0.6.5

Weakness: CWE-407 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References