Vulnerability · Published Oct 29, 2026 · Assigned by GitHub_M

CVE-2026-119195pyasn1: Quadratic-time denial of service in constructed string and indefinite-length ANY decoding

High 7.5

In plain English

A high-severity security flaw in pyasn1 from pyasn1. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.5%top 55.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

pyasn1 is a generic ASN.1 library for Python. Prior to 0.6.5, constructed string and indefinite-length ANY decoding repeatedly concatenates each fragment onto a growing bytes value. Attacker-controlled BER or CER data can use many constructed OCTET STRING or character-string fragments. DER rejects constructed OCTET STRING without a schema, but accepts its definite-length form when asn1Spec selects univ.OctetString; it also accepts constructed character strings such as UTF8String without a schema, even though those encodings are not valid DER. The separate indefinite-length ANY path is reachable in BER and CER when asn1Spec selects univ.Any; DER rejects indefinite lengths. OctetStringPayloadDecoder uses growing header concatenation and AnyPayloadDecoder.indefLenValueDecoder uses growing chunk concatenation, repeatedly copying an increasing prefix and causing quadratic work. A sufficiently fragmented value can occupy decoding workers and cause CPU exhaustion without confidentiality or integrity impact. This issue is fixed in version 0.6.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12pyasn1no fix listedDEBIAN-CVE-2026-119195
Debian:13pyasn1no fix listedDEBIAN-CVE-2026-119195
Debian:14pyasn10.6.5-1DEBIAN-CVE-2026-119195
PyPIpyasn10.6.5GHSA-9m75-vc3g-4x39
Ubuntu:22.04:LTSpyasn1no fix listedUBUNTU-CVE-2026-119195
Ubuntu:24.04:LTSpyasn1no fix listedUBUNTU-CVE-2026-119195
Ubuntu:26.04:LTSpyasn1no fix listedUBUNTU-CVE-2026-119195
Ubuntu:26.10pyasn1no fix listedUBUNTU-CVE-2026-119195

Affected products (as reported)

VendorProductVersions
pyasn1 pyasn1 < 0.6.5

Weakness: CWE-407 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References