Vulnerability · Published Oct 28, 2026 · Assigned by GitHub_M
CVE-2026-118254Highcharts Grid: pagination language options are parsed as HTML
High 8.6
In plain English
A high-severity cross-site scripting in grid-lite from @highcharts. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 36% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Highcharts JS is a JavaScript charting library based on SVG. From 2.0.0 until 3.2.0, Highcharts Grid writes pagination language strings into the DOM as markup instead of text. An attacker who controls the Grid language configuration can provide elements with event handlers, which execute in the hosting page origin when pagination controls render. Exploitation requires pagination to be enabled but does not require additional user interaction. This issue is fixed in 3.2.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @highcharts/grid-lite | 3.2.0 | GHSA-r5wg-q8fc-p6w2 |
| npm | @highcharts/grid-pro | 3.2.0 | GHSA-r5wg-q8fc-p6w2 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| highcharts | highcharts | < 13.0.0-beta.2 |
| @highcharts | grid-lite | >= 2.0.0, < 3.2.0 |
| @highcharts | grid-pro | >= 2.0.0, < 3.2.0 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N