Vulnerability · Published Oct 28, 2026 · Assigned by GitHub_M
CVE-2026-118245Highcharts Dashboards: `chartConstructor` is an unchecked lookup into the Highcharts namespace
High 8.6
In plain English
A high-severity cross-site scripting in dashboards from @highcharts. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 27% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Highcharts JS is a JavaScript charting library based on SVG. From 1.0.0 until 4.2.2, Highcharts Dashboards uses chartConstructor as an unchecked property lookup in the Highcharts namespace and invokes the selected member with the component container and chartOptions. An attacker who controls dashboard configuration can select a public utility function instead of a supported chart constructor, causing attacker-controlled options to be copied to the container as properties or attributes. Markup and event handlers can then execute in the hosting page origin when the board renders. No user interaction beyond rendering the board is required. This issue is fixed in 4.2.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | @highcharts/dashboards | 4.2.2 | GHSA-grj7-r4jv-pw9j |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| highcharts | highcharts | < 13.1.0 |
| @highcharts | dashboards | >= 1.0.0, < 4.2.3 |
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N