Vulnerability · Published Oct 27, 2026 · Assigned by GitHub_M

CVE-2026-116675TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization

High 8.5

In plain English

A high-severity cross-site scripting in tinymce from tinymce. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.5High
Exploit odds (30 days)0.3%top 71.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

TinyMCE is an open source rich text editor. From 7.9.3 until 7.9.4 and from 8.5.1 until 8.9.3, the media plugin creates elements crafted through data-mce-object in the active document before sanitization. Those elements can execute malicious scripts during processing, resulting in stored cross-site scripting for users with the media plugin enabled. This issue is fixed in versions 8.9.3 and 7.9.4.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
NuGettinymce8.9.3GHSA-mf2p-h6hf-fcwm
NuGettinymce7.9.4GHSA-mf2p-h6hf-fcwm
Packagisttinymce/tinymce8.9.3GHSA-mf2p-h6hf-fcwm
Packagisttinymce/tinymce7.9.4GHSA-mf2p-h6hf-fcwm
npmtinymce8.9.3GHSA-mf2p-h6hf-fcwm
npmtinymce7.9.4GHSA-mf2p-h6hf-fcwm

Affected products (as reported)

VendorProductVersions
tinymce tinymce >= 8.5.1, < 8.9.3>= 7.9.3, < 7.9.4

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References