Vulnerability · Published Oct 26, 2026 · Assigned by GitHub_M

CVE-2026-115922ONNX: Denial of service via unchecked expansion of packed sub-byte tensors in ONNX Python APIs

Medium 6.2

In plain English

A medium-severity security flaw in onnx from onnx. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 3% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.2Medium
Exploit odds (30 days)0.1%top 97.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. Prior to 1.22.0, _unpack_2bit() and _unpack_4bit() resize unpacked arrays according to attacker-controlled TensorProto.dims without verifying that raw_data or int32_data encodes the declared number of elements. Materializing an untrusted UINT2, INT2, UINT4, INT4, or FLOAT4E2M1 tensor through onnx.numpy_helper.to_array() or onnx.reference.ReferenceEvaluator can therefore expand a small packed payload into a disproportionately large allocation and exhaust memory. This issue is fixed in version 1.22.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12onnxno fix listedDEBIAN-CVE-2026-115922
Debian:13onnxno fix listedDEBIAN-CVE-2026-115922
Debian:14onnxno fix listedDEBIAN-CVE-2026-115922
PyPIonnx1.22.0GHSA-q69g-f4f5-v8m7
Ubuntu:22.04:LTSonnxno fix listedUBUNTU-CVE-2026-115922
Ubuntu:26.04:LTSonnxno fix listedUBUNTU-CVE-2026-115922
Ubuntu:26.10onnxno fix listedUBUNTU-CVE-2026-115922

Affected products (as reported)

VendorProductVersions
onnx onnx < 1.22.0

Weakness: CWE-789 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References