Vulnerability · Published Oct 26, 2026 · Assigned by GitHub_M

CVE-2026-115918vLLM: Responses API bypasses trust_request_chat_template for chat_template_kwargs

Medium 6.5

In plain English

A medium-severity uncontrolled resource consumption in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 71.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models. From 0.16.0 until 0.32.0, the /v1/responses endpoint allows an authenticated caller to place an attacker-controlled template in chat_template_kwargs[chat_template] when no server template is configured. ChatParams.get_apply_chat_template_kwargs() preserves that value without enforcing trust_request_chat_template, so the request can bypass the intended trust policy and cause CPU or memory exhaustion through Jinja rendering. This issue is fixed in version 0.32.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.32.0GHSA-x567-49g5-p4cf
PyPIvllm0.32.0PYSEC-2026-4349

Affected products (as reported)

VendorProductVersions
vllm-project vllm >= 0.16.0, < 0.32.0

Weakness: CWE-400, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References