Vulnerability · Published Oct 26, 2026 · Assigned by GitHub_M

CVE-2026-115917vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server

Low 3.4

In plain English

A low-severity security flaw in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 15% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.4Low
Exploit odds (30 days)0.2%top 84.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.32.0GHSA-vvpg-rrww-wpmh
PyPIvllm0.32.0PYSEC-2026-4348

Affected products (as reported)

VendorProductVersions
vllm-project vllm < 0.32.0

Weakness: CWE-942 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N

References