Vulnerability · Published Oct 26, 2026 · Assigned by GitHub_M

CVE-2026-115915vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

High 8.1

In plain English

A high-severity improper input validation in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.1High
Exploit odds (30 days)0.7%top 48.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.32.0GHSA-h3rc-j82p-2c3h
PyPIvllm0.32.0PYSEC-2026-4346

Affected products (as reported)

VendorProductVersions
vllm-project vllm < 0.32.0

Weakness: CWE-20, CWE-183 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

References