Vulnerability · Published Oct 26, 2026 · Assigned by GitHub_M

CVE-2026-115914vLLM DeepSeek-OCR image processing vulnerable to denial of service

Medium 6.5

In plain English

A medium-severity security flaw in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 34% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 65.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models. From 0.11.1 until 0.32.0, the DeepSeek-OCR, DeepSeek-OCR-2, and Unlimited-OCR image path allows a remote client that can reach the OpenAI-compatible API to submit a legal image whose normalized pixels sum to zero when that image is alone in its per-step encoder batch. _parse_and_validate_image_input returns no embedding, embed_multimodal propagates that value, and sanity_check_mm_encoder_outputs triggers a fatal assertion that shuts down the engine for all users. This issue is fixed in version 0.32.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.32.0GHSA-gq5q-89c7-vhvx

Affected products (as reported)

VendorProductVersions
vllm-project vllm >= 0.11.1, < 0.32.0

Weakness: CWE-617 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References