Vulnerability · Published Oct 26, 2026 · Assigned by GitHub_M

CVE-2026-115907zip: legacy Shrink/Reduce/Implode decoder: denial of service from attacker-controlled ZIP64 uncompressed size

High 7.5

In plain English

A high-severity uncontrolled resource consumption in zip2 from zip-rs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 29% of all known vulnerabilities).

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 71.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

zip is a zip library for Rust that supports reading and writing simple ZIP files. From 5.1.0 until 9.0.0, applications built with the legacy-zip feature can reserve output capacity from an attacker-controlled ZIP64 uncompressed size before validating the compressed stream. The ShrinkDecoder path in src/legacy/shrink.rs can panic with a capacity overflow during ZipArchive::extract, and the Reduce and Implode decoders contain the same unbounded preallocation pattern. An unhandled panic can terminate an archive-processing service. This issue is fixed in version 9.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rust-zipno fix listedDEBIAN-CVE-2026-115907
Debian:13rust-zipno fix listedDEBIAN-CVE-2026-115907
Debian:14rust-zipno fix listedDEBIAN-CVE-2026-115907
Ubuntu:26.04:LTSrust-zipno fix listedUBUNTU-CVE-2026-115907
Ubuntu:26.10rust-zipno fix listedUBUNTU-CVE-2026-115907

Affected products (as reported)

VendorProductVersions
zip-rs zip2 >= 5.1.0, < 9.0.0

Weakness: CWE-400, CWE-789 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References