Vulnerability · Published Oct 22, 2026 · Assigned by AMZN
CVE-2026-115419Unintended disclosure of data element to wrong session in Strands Agents SDK A2A Server
High 8.1
In plain English
A high-severity security flaw in strands-agents from AWS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
The A2A server component in Amazon Strands Agents SDK for Python before 1.43.0 and Amazon Strands Agents SDK for TypeScript before 1.5.0 does not properly isolate conversation state between callers. An authenticated remote user could read other tenants' conversation history and add persistent instructions that alter model behavior for subsequent callers via HTTP requests to the A2A endpoint using a different context_id. To mitigate this issue, users should upgrade to strands-agents 1.43.0 (Python) or @strands-agents/sdk 1.5.0 (TypeScript).
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | strands-agents | 1.43.0 | GHSA-4v6f-7vjh-6x4m |
| npm | @strands-agents/sdk | 1.5.0 | GHSA-4v6f-7vjh-6x4m |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| AWS | strands-agents | 0 – before 1.43.0 |
| AWS | strands-agents/sdk | 0 – before 1.5.0 |
Weakness: CWE-488 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
References
- https://pypi.org/project/strands-agents/1.43.0/ release-notes, patch
- https://www.npmjs.com/package/@strands-agents/sdk/v/1.5.0 release-notes, patch
- https://aws.amazon.com/security/security-bulletins/2026-146-aws/ vendor-advisory
- https://github.com/strands-agents/harness-sdk/security/advisories/GHSA-4v6f-7vjh-6x4m third-party-advisory