Vulnerability · Published Oct 22, 2026 · Assigned by mitre
CVE-2026-114718
Medium 4.7
In plain English
A medium-severity cross-site scripting in Webmail from Roundcube. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Roundcube Webmail before 1.6.20 and 1.7.x before 1.7.5 is affected by a cross-site scripting vulnerability in the password plugin. Error text returned by a password driver was concatenated into the message presented to the user without HTML escaping, so a backend able to influence that text, such as the DirectAdmin API, could inject script into the Roundcube interface. Upstream fixed this in the commit “Fix XSS issue in handling of password driver error responses”, which escapes the driver message before display.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | roundcube | no fix listed | DEBIAN-CVE-2026-114718 |
| Debian:13 | roundcube | 1.6.20+dfsg-0+deb13u1 | DEBIAN-CVE-2026-114718 |
| Debian:14 | roundcube | 1.6.20+dfsg-1 | DEBIAN-CVE-2026-114718 |
| Ubuntu:26.10 | roundcube | no fix listed | UBUNTU-CVE-2026-114718 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
References
- https://bugs.debian.org/1151279 issue-tracking, third-party-advisory
- https://github.com/roundcube/roundcubemail/commit/16bbca70b668e85332f23333946a764865bead94 patch
- https://roundcube.net/news/2026/10/19/security-updates-1.6.20-and-1.7.5 vendor-advisory, release-notes
- https://github.com/roundcube/roundcubemail/releases/tag/1.7.5 release-notes, patch
- https://github.com/roundcube/roundcubemail/releases/tag/1.6.20 release-notes, patch
- https://github.com/roundcube/roundcubemail/commit/94298856ee67ff7817cc4def2adb634be91e28c7 patch