Vulnerability · Published Oct 22, 2026 · Assigned by GitHub_M

CVE-2026-114620Authlib: Unvalidated request_uri fetch in JWT-secured authorization request (JAR) leading to SSRF

Medium 5.4

In plain English

A medium-severity server-side request forgery in authlib from authlib. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.4%top 67.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.9.0, Authlib's RFC 9101 JWTAuthenticationRequest passes the unauthenticated, client-controlled request_uri parameter to the abstract get_request_object() hook before applying a destination or registration policy; the hook itself performs no network request, while the documentation demonstrates an unrestricted HTTP fetch. In deployments whose integrator implements that hook as an unrestricted outbound fetch, a remote attacker who knows a valid public client identifier can make the authorization server request internal, link-local, or otherwise unintended URLs and can distinguish fetch outcomes through different error responses and timing. Deployments whose custom hook already applies a secure allowlist, destination controls, and retrieval limits are not affected. The JWTAuthenticationRequest implementation in authlib/oauth2/rfc9101/authorization_server.py forwards request_uri to get_request_object() before an application-approved retrieval policy accepts the destination. This issue is fixed in version 1.9.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12python-authlibno fix listedDEBIAN-CVE-2026-114620
Debian:13python-authlibno fix listedDEBIAN-CVE-2026-114620
Debian:14python-authlib1.9.1-1DEBIAN-CVE-2026-114620
PyPIauthlib1.9.0GHSA-x4rv-c3wx-4cr8
PyPIauthlib1.9.0PYSEC-2026-4360
Ubuntu:26.10python-authlibno fix listedUBUNTU-CVE-2026-114620

Affected products (as reported)

VendorProductVersions
authlib authlib < 1.9.0

Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N

References