Vulnerability · Published Jun 6, 2026 · Assigned by VulDB
CVE-2026-11438theonedev projects improper authorization
Medium 6.3
In plain English
A medium-severity security flaw in onedev from theonedev. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities).
Official description
A vulnerability has been found in theonedev onedev up to 15.0.5. Affected by this vulnerability is an unknown functionality of the file /projects. The manipulation of the argument project.forkedFromId leads to improper authorization. The attack is possible to be carried out remotely. Upgrading to version 15.0.6 addresses this issue. Upgrading the affected component is recommended.
Affected products (as reported)
Weakness: CWE-285, CWE-266 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L/E:X/RL:O/RC:C
References
- VDB-369018 | theonedev projects improper authorization vdb-entry, technical-description
- VDB-369018 | CTI Indicators (IOB, IOC, TTP, IOA) signature, permissions-required
- CVE-2026-11438 | CVE Analysis and Report third-party-advisory
- Submit #822944 | theonedev onedev 15.05 BOPLA third-party-advisory
- https://www.cnblogs.com/aibot/p/19994142 related
- https://github.com/theonedev/onedev/releases/tag/v15.0.6 patch