Vulnerability · Published Oct 21, 2026 · Assigned by GitHub_M

CVE-2026-114139Sentry-Javascript: Middleware Bypass when using Tunnel route

Critical 9.1

In plain English

A critical-severity security flaw in sentry-javascript from getsentry. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.1Critical
Exploit odds (30 days)0.5%top 56.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Sentry-Javascript is an official Sentry SDKs for JavaScript. From 9.36.0 until 9.47.2, 10.75.2, and 11.0.0-rc.1, the webpack integration for @sentry/nextjs skips application middleware for every request path under a configured tunnelRoute, while the tunnel rewrite serves only the exact tunnel path with valid o and p query parameters. When an application route directly collides with the tunnel path or a root dynamic segment resolves under it, an unauthenticated request can reach that route without middleware authorization. Exploitation requires tunnelRoute, a webpack build, a colliding route, and middleware being the only authorization control. This issue is fixed in versions 9.47.2, 10.75.2, and 11.0.0-rc.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@sentry/nextjs9.47.2GHSA-mchm-gjx6-7h55
npm@sentry/nextjs10.75.2GHSA-mchm-gjx6-7h55
npm@sentry/nextjs11.0.0-rc.1GHSA-mchm-gjx6-7h55

Affected products (as reported)

VendorProductVersions
getsentry sentry-javascript >= 9.36.0, < 9.47.2>= 10.0.0-alpha.0, < 10.75.2>= 11.0.0-alpha.0, < 11.0.0-rc.1

Weakness: CWE-693 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

References