Vulnerability · Published Oct 21, 2026 · Assigned by GitHub_M

CVE-2026-114135Jupyter Server: Gateway WebSocket handler bypasses kernel execute authorization

High 8.8

In plain English

A high-severity missing authorization in jupyter_server from jupyter-server. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 42% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.5%top 58.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Jupyter Server is the backend for Jupyter web applications. From 2.0.0 until 2.6.0, enabling GatewayClient.url replaced the normal KernelWebsocketHandler with WebSocketChannelsHandler, which authenticated the user but did not call authorizer.is_authorized(...) for the execute action on the kernels resource. A restricted authenticated user could therefore open an upstream kernel channel and obtain kernel execution despite the configured Authorizer denying that action, exposing data and credentials available to the kernel and permitting modification or disruption of the kernel environment. The default gateway configuration is fixed in version 2.6.0. In 2.6.0 and later, the same authorization bypass remains possible when a deployment manually registers the deprecated jupyter_server.gateway.handlers module, because its handler still omits the configured kernel-execute authorization decision.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12jupyter-serverno fix listedDEBIAN-CVE-2026-114135
Debian:13jupyter-serverno fix listedDEBIAN-CVE-2026-114135
Debian:14jupyter-serverno fix listedDEBIAN-CVE-2026-114135
PyPIjupyter-server2.6.0GHSA-354v-3q48-cv69
Ubuntu:22.04:LTSjupyter-serverno fix listedUBUNTU-CVE-2026-114135
Ubuntu:24.04:LTSjupyter-serverno fix listedUBUNTU-CVE-2026-114135
Ubuntu:26.04:LTSjupyter-serverno fix listedUBUNTU-CVE-2026-114135
Ubuntu:26.10jupyter-serverno fix listedUBUNTU-CVE-2026-114135

Affected products (as reported)

VendorProductVersions
jupyter-server jupyter_server >= 2.0.0, < 2.6.0

Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References