Vulnerability · Published Nov 5, 2026 · Assigned by GitHub_M
CVE-2026-114134Black: GitHub Action installs unvalidated required-version from pyproject.toml
High 8.7
In plain English
A high-severity security flaw in black from psf. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 35% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Black is the uncompromising Python code formatter. Prior to 26.10.1, the Black GitHub Action with use_pyproject: true accepts tool.black.required-version from pyproject.toml without validating that it is a released Black version specifier. An attacker who can submit a pull request can change that field to a direct reference to attacker-controlled code, causing the workflow to install and execute the code in the victim repository's GitHub Actions context. This issue is fixed in version 26.10.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | black | 26.10.1 | GHSA-cg8m-r9f2-5wm2 |
Affected products (as reported)
Weakness: CWE-829 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/psf/black/security/advisories/GHSA-cg8m-r9f2-5wm2 x_refsource_CONFIRM
- https://github.com/psf/black/pull/5510 x_refsource_MISC
- https://github.com/psf/black/commit/ac1f71563aeccf73cf13ece00f231d9d6c66a514 x_refsource_MISC