Vulnerability · Published Jun 5, 2026 · Assigned by AMZN

CVE-2026-11400Privilege Escalation in AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL

High 8.0

In plain English

A high-severity security flaw in AWS Advanced JDBC Wrapper from AWS. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 43% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.0High
Exploit odds (30 days)0.5%top 57.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL will allow a remote authenticated low-privilege actor to escalate privileges to those of another Amazon RDS user, including rds_superuser, via a crafted function created by the actor that runs when that user connects to the cluster through an affected wrapper. To remediate this issue, users should upgrade to AWS Advanced JDBC Wrapper version 4.0.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavensoftware.amazon.jdbc:aws-advanced-jdbc-wrapper4.0.1GHSA-mhww-p97m-3368

Affected products (as reported)

VendorProductVersions
AWS AWS Advanced JDBC Wrapper 3.0.0 – before 4.0.1

Weakness: CWE-426 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

References