Vulnerability · Published Oct 20, 2026 · Assigned by GitHub_M

CVE-2026-113665ApostropheCMS: Missing Authorization on Notification PATCH/DELETE Endpoints

Low 3.7

In plain English

A low-severity authorization bypass via user-controlled key in apostrophe from apostrophecms. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 29% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.3%top 71.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.33.0, the notification module exposes PATCH and DELETE REST endpoints that perform operations directly on the underlying MongoDB collection without verifying that the requester is authenticated or owns the target notification. As a result, an unauthenticated attacker who obtains a valid notification ID can modify or permanently delete another user's notification. This issue is fixed in version 4.33.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmapostrophe4.33.0GHSA-vwwx-px9w-crrc

Affected products (as reported)

VendorProductVersions
apostrophecms apostrophe < 4.33.0

Weakness: CWE-639, CWE-862 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

References