Vulnerability · Published Oct 20, 2026 · Assigned by GitHub_M

CVE-2026-112958ApostropheCMS: Stored XSS via Unescaped Widget Style Attribute Serialization

Medium 5.4

In plain English

A medium-severity cross-site scripting in apostrophe from apostrophecms. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.4Medium
Exploit odds (30 days)0.3%top 76.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, a project-defined free-form widget style field can carry an editor-controlled quote into an inline style attribute because the wrapper serializer does not apply HTML-attribute encoding. The quote can terminate the style attribute and inject executable attributes when published content, or an affected draft viewed by a higher-privileged user, is rendered. This issue is fixed in version 4.34.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmapostrophe4.34.0GHSA-7jg5-frgc-c67w

Affected products (as reported)

VendorProductVersions
apostrophecms apostrophe < 4.34.0

Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References