Vulnerability · Published Oct 19, 2026 · Assigned by GitHub_M

CVE-2026-112900Pillow: Argument Injection in Ghostscript call, potentially leading into RCE

Critical 9.2

In plain English

A critical-severity OS command injection in Pillow from python-pillow. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 1.3% (higher than 71% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)9.2Critical
Exploit odds (30 days)1.3%top 29.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack tooling1Public PoC

Official description

Pillow is a Python imaging library. From 2.6.0 until 13.0.0, Pillow is vulnerable to argument injection when invoking Ghostscript for EPS input. EpsImagePlugin.Ghostscript passes a caller-controlled input filename after -f without converting it to a safe absolute path, so a name beginning with a hyphen can be interpreted as a Ghostscript option. An attacker who controls the filename can inject Ghostscript arguments. Arbitrary command execution specifically requires a leading @ argument-file filename and control of the referenced text file containing additional Ghostscript arguments; the reported chain reproduces with the default -dSAFER invocation. This issue is fixed in version 13.0.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8python3-pillow5.1.1-36.el8_10ALSA-2026:93077
AlmaLinux:8python3-pillow-devel5.1.1-36.el8_10ALSA-2026:93077
AlmaLinux:8python3-pillow-doc5.1.1-36.el8_10ALSA-2026:93077
AlmaLinux:8python3-pillow-tk5.1.1-36.el8_10ALSA-2026:93077
Debian:12pillowno fix listedDEBIAN-CVE-2026-112900
Debian:13pillowno fix listedDEBIAN-CVE-2026-112900
Debian:14pillowno fix listedDEBIAN-CVE-2026-112900
PyPIpillow13.0.0GHSA-w889-685w-c8fh
Rocky Linux:8python-pillow0:5.1.1-36.el8_10RLSA-2026:93077
Ubuntu:22.04:LTSpillowno fix listedUBUNTU-CVE-2026-112900
Ubuntu:24.04:LTSpillowno fix listedUBUNTU-CVE-2026-112900
Ubuntu:26.04:LTSpillowno fix listedUBUNTU-CVE-2026-112900
Ubuntu:26.10pillowno fix listedUBUNTU-CVE-2026-112900

Affected products (as reported)

VendorProductVersions
python-pillow Pillow >= 2.6.0, < 13.0.0

Weakness: CWE-78, CWE-88 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

References