Vulnerability · Published Oct 19, 2026 · Assigned by GitHub_M
CVE-2026-112394Pillow: P;2L and P;4L decoders may read 1 to 3 bytes past the passed buffer size
Medium 6.3
In plain English
A medium-severity security flaw in Pillow from python-pillow. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Pillow is a Python imaging library. Prior to 13.0.0, Pillow's P;2L and P;4L raw decoders can read past the end of an input buffer. ImagingRawDecode calculates a packed-pixel row size, while the unpackers read separately padded bit planes. A caller can supply a buffer and image dimensions whose accepted size is smaller than the unpacker's actual footprint. This can disclose up to three adjacent heap bytes in output pixels or crash the process. This issue is fixed in version 13.0.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | pillow | no fix listed | DEBIAN-CVE-2026-112394 |
| Debian:13 | pillow | no fix listed | DEBIAN-CVE-2026-112394 |
| Debian:14 | pillow | no fix listed | DEBIAN-CVE-2026-112394 |
| PyPI | pillow | 13.0.0 | GHSA-4558-3h8r-v8xp |
| PyPI | pillow | 13.0.0 | PYSEC-2026-4327 |
| Ubuntu:22.04:LTS | pillow | no fix listed | UBUNTU-CVE-2026-112394 |
| Ubuntu:24.04:LTS | pillow | no fix listed | UBUNTU-CVE-2026-112394 |
| Ubuntu:26.04:LTS | pillow | no fix listed | UBUNTU-CVE-2026-112394 |
| Ubuntu:26.10 | pillow | no fix listed | UBUNTU-CVE-2026-112394 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| python-pillow | Pillow | < 13.0.0 |
Weakness: CWE-126 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N