Vulnerability · Published Oct 22, 2026 · Assigned by openjs
CVE-2026-112085webpack-dev-server vulnerable to cross-origin WebSocket access via proxied upgrades
High 8.2
In plain English
A high-severity security flaw in webpack-dev-server from webpack-dev-server. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities).
Official description
webpack-dev-server is a development server that provides live reloading for webpack projects. In versions before 5.2.7 and in version 6.0.0, when a proxy entry is configured to forward WebSockets, the server forwards non-HMR WebSocket upgrade requests to the proxy target without validating the Host or Origin headers, so the allowedHosts protection does not apply to those proxied upgrades. A malicious web page visited by a developer can open a cross-origin WebSocket through the dev server and read from and write to the proxied backend, even when the server is bound to loopback. The issue is fixed in webpack-dev-server 5.2.7 and 6.1.0, where proxied WebSocket upgrades pass the same Host and Origin validation as the HMR WebSocket, and users should upgrade to one of those versions or later. As a workaround, omit WebSocket forwarding from proxy entries that do not need it and scope the proxy to specific paths.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Ubuntu:22.04:LTS | node-webpack | no fix listed | UBUNTU-CVE-2026-112085 |
| Ubuntu:24.04:LTS | node-webpack | no fix listed | UBUNTU-CVE-2026-112085 |
| Ubuntu:26.04:LTS | node-webpack | no fix listed | UBUNTU-CVE-2026-112085 |
| Ubuntu:26.10 | node-webpack | no fix listed | UBUNTU-CVE-2026-112085 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| webpack-dev-server | webpack-dev-server | 0 – before 5.2.76.0.0 – before 6.1.0 |
Weakness: CWE-346, CWE-1385 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N