Vulnerability · Published Nov 4, 2026 · Assigned by apache
CVE-2026-111821Apache ActiveMQ, Apache ActiveMQ KahaDB: Oversized client identifier strings poison the KahaDB journal
Unrated
In plain English
A improper input validation in Apache ActiveMQ from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities).
Official description
Improper input validation vulnerability in Apache ActiveMQ, Apache ActiveMQ KahaDB. A user can create a durable subscription with a clientId and subscription name that have a combined length > 65,535 (while separately being shorter) on a broker using KahaDB which can cause the broker to shutdown and be unrecoverable. This issue affects Apache ActiveMQ: from 6.0.0 before 6.3.3, before 5.19.12; Apache ActiveMQ KahaDB: from 6.0.0 before 6.3.3, before 5.19.12. Users are recommended to upgrade to version 6.4.0, 6.3.3 or 5.19.12, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | activemq | no fix listed | DEBIAN-CVE-2026-111821 |
| Debian:13 | activemq | no fix listed | DEBIAN-CVE-2026-111821 |
| Ubuntu:24.04:LTS | activemq | no fix listed | UBUNTU-CVE-2026-111821 |
| Ubuntu:26.04:LTS | activemq | no fix listed | UBUNTU-CVE-2026-111821 |
| Ubuntu:26.10 | activemq | no fix listed | UBUNTU-CVE-2026-111821 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache ActiveMQ | 6.0.0 – before 6.3.30 – before 5.19.12 |
| Apache Software Foundation | Apache ActiveMQ KahaDB | 6.0.0 – before 6.3.30 – before 5.19.12 |
Weakness: CWE-20