Vulnerability · Published Oct 21, 2026 · Assigned by apache
CVE-2026-111804Apache Traffic Server: wasm plugin has a use-after-free and forwards unvalidated guest metric IDs
High 8.2
In plain English
A high-severity use-after-free in Apache Traffic Server from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities).
Official description
Apache Traffic Server's experimental wasm plugin has a use-after-free in its transaction-close handler and forwards unvalidated guest-supplied metric IDs to the internal stats API. This issue affects Apache Traffic Server: from 10.0.0 through 10.1.4, 10.2.0. Users are recommended to upgrade to version 10.1.5 or 10.2.1, which fix the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | trafficserver | no fix listed | DEBIAN-CVE-2026-111804 |
| Ubuntu:24.04:LTS | trafficserver | no fix listed | UBUNTU-CVE-2026-111804 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Traffic Server | 10.0.0 – through 10.1.410.2.0 |
Weakness: CWE-416 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
References
- https://lists.apache.org/thread/r95dq29ywcd1f4x30snxlqmb12z4s4kc vendor-advisory