Vulnerability · Published Oct 19, 2026 · Assigned by GitHub_M
CVE-2026-111766markdown-it: Quadratic-time denial of service in inline HTML parsing with html enabled
Low 3.7
In plain English
A low-severity uncontrolled resource consumption in markdown-it from markdown-it. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
markdown-it is a Markdown parser. Prior to 14.3.3 and 15.0.3, when the html option or commonmark preset is enabled and the constructs occur inside a paragraph, attacker-controlled Markdown containing repeated unterminated inline HTML comments, processing instructions, declarations, or CDATA sections reaches src/rules_inline/html_inline.ts. Its HTML_TAG_RE match searches the remaining suffix for the appropriate terminator; when no terminator is present, parsing advances to the next opener and repeats the match over overlapping input, causing quadratic processing and denial of service through event-loop blocking or an unresponsive browser main thread. HTML blocks and the default HTML-disabled configuration are not affected by these payloads. This issue is fixed in versions 14.3.3 and 15.0.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-markdown-it | no fix listed | DEBIAN-CVE-2026-111766 |
| Debian:13 | node-markdown-it | no fix listed | DEBIAN-CVE-2026-111766 |
| Debian:14 | node-markdown-it | no fix listed | DEBIAN-CVE-2026-111766 |
| Ubuntu:22.04:LTS | node-markdown-it | no fix listed | UBUNTU-CVE-2026-111766 |
| Ubuntu:24.04:LTS | node-markdown-it | no fix listed | UBUNTU-CVE-2026-111766 |
| Ubuntu:26.04:LTS | node-markdown-it | no fix listed | UBUNTU-CVE-2026-111766 |
| Ubuntu:26.10 | node-markdown-it | no fix listed | UBUNTU-CVE-2026-111766 |
| npm | markdown-it | 15.0.3 | GHSA-vfgh-jcmw-g37q |
| npm | markdown-it | 14.3.3 | GHSA-vfgh-jcmw-g37q |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| markdown-it | markdown-it | >= 15.0.0, < 15.0.3< 14.3.3 |
Weakness: CWE-400, CWE-407 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
References
- https://github.com/markdown-it/markdown-it/security/advisories/GHSA-vfgh-jcmw-g37q x_refsource_CONFIRM
- https://github.com/markdown-it/markdown-it/commit/928bc8c11ded60181c0e7fc5aa954eec582e8e79 x_refsource_MISC
- https://github.com/markdown-it/markdown-it/commit/d99f48839d37af6fd8a2617516c43dab90755503 x_refsource_MISC
- https://github.com/markdown-it/markdown-it/releases/tag/14.3.3 x_refsource_MISC
- https://github.com/markdown-it/markdown-it/releases/tag/15.0.3 x_refsource_MISC