Vulnerability · Published Oct 22, 2026 · Assigned by openjs

CVE-2026-111181body-parser vulnerable to Denial of Service via trailing bytes after a compressed request body

High 7.5

In plain English

A high-severity security flaw in body-parser from body-parser. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.4%top 66.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

body-parser is body parsing middleware for Node.js and Express. In versions before 1.20.9 and in versions from 2.0.0 before 2.4.0, a single request can crash any application using body-parser with default options. When a request carries a Content-Encoding such as gzip, body-parser pipes it into a decompression stream and, after reading the body, leaves that stream with no error listener. A payload of one valid compressed frame followed by trailing bytes decodes and the application responds normally, but the trailing bytes then reach the already-finished decoder, which emits an error that is re-thrown as an uncaught exception and terminates the process. No matching route is required because body parsing runs before routing, so any endpoint that parses a body is affected. The issue is fixed in body-parser 2.4.0 and 1.20.9, and users should upgrade to one of those versions or later. As a workaround, disable request-body inflation (set the body-parser inflate option to false) so encoded requests are rejected before any decompression stream is created.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-body-parserno fix listedDEBIAN-CVE-2026-111181
Debian:13node-body-parserno fix listedDEBIAN-CVE-2026-111181
Debian:14node-body-parser2.4.0+~1.19.6-1DEBIAN-CVE-2026-111181
Ubuntu:22.04:LTSnode-body-parserno fix listedUBUNTU-CVE-2026-111181
Ubuntu:24.04:LTSnode-body-parserno fix listedUBUNTU-CVE-2026-111181
Ubuntu:26.04:LTSnode-body-parserno fix listedUBUNTU-CVE-2026-111181
Ubuntu:26.10node-body-parserno fix listedUBUNTU-CVE-2026-111181
npmbody-parser1.20.9GHSA-27r3-jxmh-p828
npmbody-parser2.4.0GHSA-27r3-jxmh-p828

Affected products (as reported)

VendorProductVersions
body-parser body-parser 2.0.0 – before 2.4.00 – before 1.20.9

Weakness: CWE-248 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References