Vulnerability · Published Oct 20, 2026 · Assigned by openjs

CVE-2026-110725fast-uri vulnerable to scheme injection via an unescaped first-segment colon in suffix references

Low 3.7

In plain English

A low-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.3%top 76.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, when serialize(), normalize(), or resolve() are called with the non-default option reference set to suffix on a reference that has no authority, the emitted relative reference can contain a bare colon in its first path segment without escaping it, even though RFC 3986 forbids that because it makes the string reparse as an absolute URI with a scheme. An application that serializes or normalizes a relative reference with the suffix option and then treats the result as a URI can turn inert input into a live javascript, data, or vbscript URL, a cross-site scripting vector, and the equal() comparison can conflate a scheme-bearing reference with a relative one. Exposure is limited to applications using the non-default suffix reference option. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, avoid the suffix reference option on untrusted input, or percent-encode a colon in the first path segment of the result before treating it as a URI.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-ajvno fix listedDEBIAN-CVE-2026-110725
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-110725
Debian:14node-ajv8.20.0~ds+~cs7.2.4-1DEBIAN-CVE-2026-110725
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-110725
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-110725
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-110725
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-110725
npmfast-uri4.2.3GHSA-333x-w4r6-6crp
npmfast-uri3.1.9GHSA-333x-w4r6-6crp
npmfast-uri2.4.8GHSA-333x-w4r6-6crp

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 0 – before 2.4.83.0.0 – before 3.1.94.0.0 – before 4.2.3

Weakness: CWE-41, CWE-116 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

References