Vulnerability · Published Oct 14, 2026 · Assigned by AMZN
CVE-2026-110310RSA PKCS#1 v1.5 padding oracle via legacy envelope key format downgrade in Amazon S3 Encryption Client for .NET
Medium 5.3
In plain English
A medium-severity security flaw in Amazon.Extensions.S3.Encryption from Amazon. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities).
Official description
A remote user who can read encrypted objects in the S3 bucket can force a padding downgrade by altering the padding scheme recorded in an object's metadata to legacy PKCS#1 v1.5. Since this padding scheme is susceptible to the well-known Bleichenbacher attack, the user can use a PKCS#1 v1.5 padding oracle to recover the RSA-wrapped envelope key and decrypt the object. To remediate this issue, we recommend that users upgrade to version 3.2.2 or 4.0.3. The 1.x and 2.x lines will not be patched, users of those lines need to migrate to 3.2.2 or 4.0.3.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Amazon | Amazon.Extensions.S3.Encryption | 2.1.0 – through 2.*3.0.0 – through 3.2.14.0.0 – through 4.0.2 |
Weakness: CWE-204, CWE-757 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
References
- https://www.nuget.org/packages/Amazon.Extensions.S3.Encryption/3.2.2 release-notes, patch
- https://www.nuget.org/packages/Amazon.Extensions.S3.Encryption/4.0.3 release-notes, patch
- https://aws.amazon.com/security/security-bulletins/2026-135-aws/ vendor-advisory
- https://github.com/aws/amazon-s3-encryption-client-dotnet/security/advisories/GHSA-322w-f6rw-r4fj third-party-advisory