Vulnerability · Published Oct 20, 2026 · Assigned by openjs
CVE-2026-110180fast-uri vulnerable to host confusion via unchecked WHATWG host canonicalization
Medium 4.8
In plain English
A medium-severity improper input validation in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions from 2.4.2 through 2.4.7, from 3.1.3 through 3.1.8, and from 4.0.1 through 4.2.2, for HTTP-family schemes the canonicalizeHost() function passes the parsed host to the WHATWG URL parser and adopts its hostname without checking that the parser consumed the entire input as a host, so the authority can be silently rewritten: data before an at-sign is dropped and tab, carriage-return, and line-feed characters are stripped, with no error reported. An application that enforces host-based policy such as denylists, loopback filtering, redirect validation, or outbound proxy routing on one representation can then see the canonical host diverge from what it checked, allowing traffic to be steered to an unintended destination. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, reject an authority that contains more than one at-sign or any tab, carriage-return, or line-feed before calling fast-uri, or treat any non-empty parse error as fatal and compare hosts only from the same parse result.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-ajv | no fix listed | DEBIAN-CVE-2026-110180 |
| Debian:13 | node-ajv | no fix listed | DEBIAN-CVE-2026-110180 |
| Debian:14 | node-ajv | 8.20.0~ds+~cs7.2.4-1 | DEBIAN-CVE-2026-110180 |
| Ubuntu:22.04:LTS | node-ajv | no fix listed | UBUNTU-CVE-2026-110180 |
| Ubuntu:24.04:LTS | node-ajv | no fix listed | UBUNTU-CVE-2026-110180 |
| Ubuntu:26.04:LTS | node-ajv | no fix listed | UBUNTU-CVE-2026-110180 |
| Ubuntu:26.10 | node-ajv | no fix listed | UBUNTU-CVE-2026-110180 |
| npm | fast-uri | 4.2.3 | GHSA-wjr9-j795-jxcr |
| npm | fast-uri | 3.1.9 | GHSA-wjr9-j795-jxcr |
| npm | fast-uri | 2.4.8 | GHSA-wjr9-j795-jxcr |
Affected products (as reported)
Weakness: CWE-20, CWE-436 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N