Vulnerability · Published Oct 20, 2026 · Assigned by openjs

CVE-2026-110095fast-uri vulnerable to improper path equivalence in relative reference normalization

Low 3.7

In plain English

A low-severity security flaw in fast-uri from fast-uri. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)3.7Low
Exploit odds (30 days)0.3%top 78.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

fast-uri is a dependency-free RFC 3986 URI parser and serializer for Node.js. In versions before 2.4.8, from 3.0.0 through 3.1.8, and from 4.0.0 through 4.2.2, the normalize() and serialize() functions apply RFC 3986 dot-segment removal to the path of a relative-path reference, even though that algorithm is defined only for the merged target path during resolution, so a leading parent-directory segment can be dropped and a document-relative reference can become root-relative. An application that normalizes an attacker-supplied or user-supplied relative reference and then resolves it, or uses it as a cache, deduplication, or authorization key, can have the reference escape its intended directory and point at a different resource. The issue is fixed in fast-uri 2.4.8, 3.1.9, and 4.2.3, and users should upgrade to one of these versions or later. As a workaround, resolve a relative reference against its absolute base first and normalize the absolute result instead of normalizing the reference beforehand.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-ajvno fix listedDEBIAN-CVE-2026-110095
Debian:13node-ajvno fix listedDEBIAN-CVE-2026-110095
Debian:14node-ajv8.20.0~ds+~cs7.2.4-1DEBIAN-CVE-2026-110095
Ubuntu:22.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-110095
Ubuntu:24.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-110095
Ubuntu:26.04:LTSnode-ajvno fix listedUBUNTU-CVE-2026-110095
Ubuntu:26.10node-ajvno fix listedUBUNTU-CVE-2026-110095
npmfast-uri4.2.3GHSA-xhq7-xmqj-769h
npmfast-uri3.1.9GHSA-xhq7-xmqj-769h
npmfast-uri2.4.8GHSA-xhq7-xmqj-769h

Affected products (as reported)

VendorProductVersions
fast-uri fast-uri 0 – before 2.4.83.0.0 – before 3.1.94.0.0 – before 4.2.3

Weakness: CWE-41 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

References