Vulnerability · Published Oct 18, 2026 · Assigned by openjs
CVE-2026-110024@fastify/jwt vulnerable to missing token expiration when per-call options drop global defaults
Medium 6.8
In plain English
A medium-severity security flaw in @fastify/jwt from @fastify/jwt. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities).
Official description
@fastify/jwt is a JWT utility plugin for Fastify. In versions prior to 10.2.5, the top-level sign and verify methods replace the globally configured defaults with the per-call options instead of merging them, so passing any per-call option silently drops every global default that the call does not restate, including temporal protections such as token expiration and maximum accepted token age. A token signed this way carries no expiration claim and never expires, and verification stops enforcing a configured maximum age, so stale or never-expiring tokens are accepted. The route-level decorators for signing and verifying already merge options and are not affected. The issue is fixed in @fastify/jwt 10.2.5, and users should upgrade to 10.2.5 or later.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| @fastify/jwt | @fastify/jwt | 0 – before 10.2.5 |
Weakness: CWE-613 · Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N