Vulnerability · Published Oct 15, 2026 · Assigned by openjs
CVE-2026-109932undici WebSocket client vulnerable to Denial of Service via unbounded automatic PONG buffering
Medium 5.9
In plain English
A medium-severity uncontrolled resource consumption in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici is an HTTP client library for Node.js. In versions 5.15.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its WebSocket client, including the bundled WebSocket exposed by Node.js, can be driven to exhaust process memory by a malicious or compromised WebSocket server. For every PING frame received, the client automatically writes a PONG response and ignores the backpressure signal from the socket write, so a server that streams small PING frames while never reading the client's PONGs makes the outbound write queue and heap grow without bound until the Node.js process runs out of memory and terminates. The attack is remote and unauthenticated, needs only a normal WebSocket connection, and is asymmetric, since small inbound PINGs produce a much larger retained outbound queue, with availability the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which pause WebSocket frame parsing when the automatic PONG response hits socket backpressure and resume on drain, bounding the outbound queue, and users should upgrade to one of those versions or later. There is no workaround.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-109932 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-109932 |
| Debian:14 | node-undici | 8.12.2+dfsg+~cs3.2.3-1 | DEBIAN-CVE-2026-109932 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-109932 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-109932 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-109932 |
| npm | undici | 8.12.2 | GHSA-9fm3-97px-rjf6 |
| npm | undici | 7.30.1 | GHSA-9fm3-97px-rjf6 |
| npm | undici | 6.29.1 | GHSA-9fm3-97px-rjf6 |
Affected products (as reported)
Weakness: CWE-400, CWE-405, CWE-770 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H