Vulnerability · Published Oct 15, 2026 · Assigned by openjs

CVE-2026-109924undici vulnerable to Denial of Service via unbounded memory in the EventSource parser

Medium 5.9

In plain English

A medium-severity resource allocation without limits in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.3%top 74.8% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

undici is an HTTP client library for Node.js. In versions 6.5.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its EventSource client can be driven to exhaust process memory by a malicious or compromised Server-Sent Events peer. By sending millions of tiny completed data fields with no blank event separator, or a single unfinished line split across many chunks, the parser retains a growing amount of per-field and per-chunk state that the byte-based maxEventSize and maxResponseSize limits do not bound, and because maxResponseSize is enforced on the compressed body before decompression, a small compressed response can expand into enough retained memory to terminate the process. An application only needs to maintain an EventSource connection to an untrusted peer, which controls only the response, and availability is the only impact. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which bound the retained parser state independently of the byte limits, and users should upgrade to one of those versions or later. There is no workaround.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12node-undicino fix listedDEBIAN-CVE-2026-109924
Debian:13node-undicino fix listedDEBIAN-CVE-2026-109924
Debian:14node-undici8.12.2+dfsg+~cs3.2.3-1DEBIAN-CVE-2026-109924
Ubuntu:24.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-109924
Ubuntu:26.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-109924
Ubuntu:26.10node-undicino fix listedUBUNTU-CVE-2026-109924
npmundici8.12.2GHSA-4qv8-2p9j-2685
npmundici7.30.1GHSA-4qv8-2p9j-2685
npmundici6.29.1GHSA-4qv8-2p9j-2685

Affected products (as reported)

VendorProductVersions
undici undici 6.5.0 – before 6.29.17.0.0 – before 7.30.18.0.0 – before 8.12.2

Weakness: CWE-770 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

References