Vulnerability · Published Oct 15, 2026 · Assigned by openjs
CVE-2026-109855undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
High 7.5
In plain English
A high-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 20% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici is an HTTP client library for Node.js. In versions 8.11.0 and 8.11.1, its experimental WebSocket client, which is enabled by default when HTTP/2 is allowed, mishandles a failed WebSocket handshake over HTTP/2: the request is already marked completed, so the abort becomes a no-op and the underlying HTTP/2 stream is left open with no error listener. When a malicious server then destroys the connection, the orphaned stream emits an unhandled error and the Node.js process exits. A remote, unauthenticated server can therefore crash any client that opens a WebSocket to it over HTTP/2, resulting in a denial of service. The issue is fixed in undici 8.11.2, and users should upgrade to 8.11.2 or later. As a workaround, set allowH2 to false to disable HTTP/2 for WebSocket connections, or avoid opening WebSocket connections to untrusted servers.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:14 | node-undici | 8.12.2+dfsg+~cs3.2.3-1 | DEBIAN-CVE-2026-109855 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-109855 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-109855 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-109855 |
| npm | undici | 8.11.2 | GHSA-qq8j-7v2v-3rwp |
Affected products (as reported)
Weakness: CWE-248, CWE-754 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H