Vulnerability · Published Oct 15, 2026 · Assigned by openjs

CVE-2026-109841undici vulnerable to Subresource Integrity bypass via non-lowercase algorithm tokens

Medium 5.9

In plain English

A medium-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 17% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.3%top 83.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

undici is an HTTP client library for Node.js. In versions 7.15.0 through 7.30.0 and 8.0.0 through 8.12.1, its fetch() implementation verifies Subresource Integrity metadata by matching the algorithm token against a lowercase-only set, even though the SRI specification defines the token by its ASCII-lowercase form, so a valid but non-lowercase token such as an uppercase or mixed-case SHA256 is treated as unknown and skipped. When no recognized algorithm remains, undici treats the integrity list as empty and accepts the response, so a server returning a body that does not match the pinned digest passes the check. An attacker who controls only the response body can therefore deliver attacker-controlled bytes to an application that pinned a valid uppercase or mixed-case SRI token, with no integrity error, affecting response integrity only. The issue is fixed in undici 7.30.1 and 8.12.2, which normalize the algorithm token to ASCII lowercase before validation, and users should upgrade to one of those versions or later. As a workaround, use lowercase algorithm tokens such as sha256, sha384, or sha512 in integrity metadata.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14node-undici8.12.2+dfsg+~cs3.2.3-1DEBIAN-CVE-2026-109841
Ubuntu:24.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-109841
Ubuntu:26.04:LTSnode-undicino fix listedUBUNTU-CVE-2026-109841
Ubuntu:26.10node-undicino fix listedUBUNTU-CVE-2026-109841
npmundici7.30.1GHSA-f72v-6w45-q472
npmundici8.12.2GHSA-f72v-6w45-q472

Affected products (as reported)

VendorProductVersions
undici undici 7.15.0 – before 7.30.18.0.0 – before 8.12.2

Weakness: CWE-178 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

References