Vulnerability · Published Oct 15, 2026 · Assigned by openjs
CVE-2026-109829undici vulnerable to cache poisoning and cross-user disclosure via cross-origin redirects
High 7.4
In plain English
A high-severity security flaw in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici is an HTTP client library for Node.js. In versions 7.0.0 through 7.30.0 and 8.0.0 through 8.12.1, when an originless Agent composes the redirect and cache interceptors in that order with a shared cache store, the cache builds its key from the original request URL before the redirect handler changes the origin, so a response produced after a cross-origin redirect is stored under the original key. An attacker who controls the target of a redirect from a trusted URL can have their response cached under that trusted URL and served to later callers, allowing persistent cache poisoning, and the same key confusion lets a private, non-stored redirect response to a user-specific resource be stored under the original URL and served to a later unauthenticated caller, disclosing private data. Applications are affected only when an originless Agent, a shared cache store, and the redirect-then-cache composition are all used. The issue is fixed in undici 7.30.1 and 8.12.2, which verify the producing origin still matches the cache key and preserve each redirect hop's cache-control policy before storing, and users should upgrade to one of those versions or later. As a workaround, compose the cache interceptor before the redirect interceptor, use per-origin dispatchers and cache stores, or disable shared caching on redirect-capable requests.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-109829 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-109829 |
| Debian:14 | node-undici | 8.12.2+dfsg+~cs3.2.3-1 | DEBIAN-CVE-2026-109829 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-109829 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-109829 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-109829 |
| npm | undici | 8.12.2 | GHSA-4w7w-5xrc-9h26 |
| npm | undici | 7.30.1 | GHSA-4w7w-5xrc-9h26 |
Affected products (as reported)
Weakness: CWE-346, CWE-524 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N