Vulnerability · Published Oct 15, 2026 · Assigned by openjs
CVE-2026-109383undici vulnerable to TLS certificate validation bypass via dropped tls options in Agent
High 7.4
In plain English
A high-severity improper certificate validation in undici from undici. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 8% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
undici is an HTTP client library for Node.js. In versions 4.0.0 through 6.29.0, 7.0.0 through 7.30.0, and 8.0.0 through 8.12.1, its Agent dispatcher passes its constructor options through a JSON-based deep clone before forwarding them to each per-origin pool, and because JSON cannot represent functions, a caller-supplied tls option containing a checkServerIdentity callback is silently dropped before it reaches the TLS layer. As a result, a TLS peer whose certificate a custom checkServerIdentity was written to reject, but which passes Node's default hostname and chain checks, is silently accepted. Because Agent is the default dispatcher behind request, fetch, and setGlobalDispatcher, this affects the path most applications use, and EnvHttpProxyAgent is affected on its direct and no-proxy routes as well, while only applications that pass a function-valued tls option such as a custom checkServerIdentity for certificate or public-key pinning are at risk. The issue is fixed in undici 6.29.1, 7.30.1, and 8.12.2, which preserve the tls option outside the JSON clone so custom verification callbacks are forwarded unchanged, and users should upgrade to one of those versions or later. As a workaround, pass the TLS options through connect instead of tls, or for proxied destinations use requestTls and proxyTls.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | node-undici | no fix listed | DEBIAN-CVE-2026-109383 |
| Debian:13 | node-undici | no fix listed | DEBIAN-CVE-2026-109383 |
| Debian:14 | node-undici | 8.12.2+dfsg+~cs3.2.3-1 | DEBIAN-CVE-2026-109383 |
| Ubuntu:24.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-109383 |
| Ubuntu:26.04:LTS | node-undici | no fix listed | UBUNTU-CVE-2026-109383 |
| Ubuntu:26.10 | node-undici | no fix listed | UBUNTU-CVE-2026-109383 |
| npm | undici | 8.12.2 | GHSA-2m5v-pch6-74hx |
| npm | undici | 7.30.1 | GHSA-2m5v-pch6-74hx |
| npm | undici | 6.29.1 | GHSA-2m5v-pch6-74hx |
Affected products (as reported)
Weakness: CWE-295 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N